2nd March 2022

[RESOLVED]Amsterdam Data Center :: Intermittent Speed & Connectivity Issues

Our Network Engineering team is currently investigating reports of intermittent connectivity & speed issues in our Amsterdam data center. Our Network Engineering team is aware of this issue and working diligently to rectify the situation. We will provide further updates as they're made available.

UPDATE 4:20AM EST: Our Engineering team continue their efforts to resolve the intermittent connectivity and speed issues affecting our Amsterdam data center. Further updates will be provided as they become available.

UPDATE 6:40AM EST: Our Engineers are still working to resolve intermittent connectivity for some users. We will provide additional updates as they are made available.

UPDATE 10:02 AM EST: Our Engineers confirmed this matter is resolved. Please contact our Guru team directly with any outstanding issues.